View topic - '55 Odometer Stopped Working

Desoto.org
http://www.desoto.org/phpbbforum/

'55 Odometer Stopped Working
http://www.desoto.org/phpbbforum/viewtopic.php?f=1&t=5718
Page 1 of 1

Author:  MarkKubancik [ Mon Aug 08, 2016 3:13 am ]
Post subject:  '55 Odometer Stopped Working

Just noticed this weekend that my '55's odometer has stopped turning. The speedometer is working fine after the cable was replaced after it shot craps on the way home from the Ft. Wayne Convention in 2014. For all I know the odometer may not have worked since the cable was replaced. What might be the cause of the odometer not working and how can it be repaired?

Mark

Author:  TimBowers [ Mon Aug 08, 2016 6:27 pm ]
Post subject:  Re: '55 Odometer Stopped Working

That might be a question best posed to someone like Bruce up at Bob's Speedometer. Maybe the odometer seized and stripped a gear or something....

Author:  MarkKubancik [ Tue Aug 09, 2016 2:45 am ]
Post subject:  Re: '55 Odometer Stopped Working

Thanks Tim. Can you share contact info for Bruce at Bob's Speedometer?

Mark

Author:  TimBowers [ Wed Aug 10, 2016 3:50 pm ]
Post subject:  Re: '55 Odometer Stopped Working

Bob’s Speedometer (speedos, tachs, clocks, gauges, gas tank sending units, cables and castings and ratio boxes)

10123 Bergin Road
Howell, MI 48843
800-592-9673
www.bobsspeedometer.com

Author:  MarkKubancik [ Thu Aug 11, 2016 3:24 am ]
Post subject:  Re: '55 Odometer Stopped Working

Thanks, will contact.

Author:  daveallard [ Sat Aug 20, 2016 2:38 am ]
Post subject:  Re: '55 Odometer Stopped Working

mine seized too a couple years ago so I took it out (a bitch of a job) and found it had a spot where it seemed to stick. luckily I still had the end from the old broked cable so I oiled everything, chucked the end in my drill and ran it fwd and back for a few minutes. freed it up so it ran smooth and reinstalled it.

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/