View topic - Fluid Leaking from Fluid Drive Unit

Desoto.org
http://www.desoto.org/phpbbforum/

Fluid Leaking from Fluid Drive Unit
http://www.desoto.org/phpbbforum/viewtopic.php?f=1&t=5993
Page 1 of 1

Author:  JayLinder [ Fri Oct 13, 2017 6:16 pm ]
Post subject:  Fluid Leaking from Fluid Drive Unit

I have a 1941 Custom with the simplimatic. A few years ago I had driven the car and was getting ready to come home and noticed a puddle of fluid under the car. Got the car home and removed the clutch pan and it appeared that it was the fluid drive unit leaking. Took me a while but last summer I finally had the unit out of the car and sent out to replace the carbon seal. Put the unit back in and it still leaked, I was getting fluid spraying(mist) on the floor, exhaust and passenger frame rail. After running I would also get a small(3in diameter) puddle under the car with a drip on the fluid drive unit. I have taken the unit back out and sent back to where I had the seal replaced. They agreed it was leaking and found what they thought was the issue. They tested the unit and did not see a leak. I have it back in the car and again and still seeing the spray(mist) from the unit and am getting a small puddle under the car.

Any ideas what is going on? Is there something else going on that is causing the unit to leak?

While I have been testing my Leak, I have also been testing the transmission shift. I have the car on jack stands. I can get the car to shift in high range but I don't notice any difference in engine speed. Shouldn't I be noticing a difference in engine speed when it shifts from 3rd to 4th in high range?

Any help or insight anyone has on these would be greatly appreciated.

Thanks,
Jay Linder

Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/